2017 © Pedro Peláez
 

library wp-basis

This library customizes HTML to use sass-basis in WordPress.

image

inc2734/wp-basis

This library customizes HTML to use sass-basis in WordPress.

  • Saturday, July 28, 2018
  • by inc2734
  • Repository
  • 1 Watchers
  • 0 Stars
  • 1,385 Installations
  • JavaScript
  • 1 Dependents
  • 0 Suggesters
  • 0 Forks
  • 0 Open issues
  • 31 Versions
  • 22 % Grown

The README.md

WP Basis

CILatest Stable Version License, (*1)

Requirements

  • Node.js

Install

$ composer require inc2734/wp-basis

How to use

<?php
// When Using composer auto loader
$Basis = new Inc2734\WP_Basis\Bootstrap();
// in style.scss
$_font-path: '/PATH/TO/vendor/inc2734/wp-basis/src/assets/packages/sass-basis/src/font' !default;
@import '/PATH/TO/vendor/inc2734/wp-basis/src/assets/packages/sass-basis/src/css/basis';
// in js
import '/PATH/TO/vendor/inc2734/wp-basis/src/assets/packages/sass-basis/src/js/basis.js';

import BasisStickyHeader from '/PATH/TO/vendor/inc2734/wp-basis/src/assets/packages/sass-basis-layout/src/js/sticky-header.js';
document.addEventListener(
  'DOMContentLoaded',
  () => {
    new BasisStickyHeader();
  },
  false
);

Walker_Nav_Menu for navbar

wp_nav_menu( [
  'walker' => new \Inc2734\WP_Basis\App\Walker\Navbar(),
] );

Walker_Nav_Menu for drawer

wp_nav_menu( [
  'walker' => new \Inc2734\WP_Basis\App\Walker\Drawer(),
] );

Filter hooks

inc2734_wp_basis_use_responsive_iframe

/**
 * Return false when you don't want to use responsive iframe
 *
 * @param boolean $use true
 * @return boolean
 */
add_filter(
  'inc2734_wp_basis_use_responsive_iframe',
  function( $use ) {
    return false;
  }
);

inc2734_wp_basis_4to3_oembed_domains

/**
 * oEmbed container size is 16 to 9.
 * Return domains if you want to make the size 4 to 3 in some domains.
 *
 * @param array $domains
 *    @var string https?:\/\/www\.slideshare\.net
 *    @var string https?:\/\/speakerdeck\.com
 * @return array
 */
add_filter(
  'inc2734_wp_basis_4to3_oembed_domains',
  function( $domains ) {
    return $domains;
  }
);
/**
 * @see https://developer.wordpress.org/reference/functions/wp_link_pages/
 * @param array $args
 * @return array
 */
add_filter(
  'inc2734_wp_basis_wp_link_pages_args',
  function( $args ) {
    return $args;
  }
);

inc2734_wp_basis_posts_pagination_args

/**
 * @see https://developer.wordpress.org/reference/functions/get_the_posts_pagination/
 * @param array $args
 * @return array
 */
add_filter(
  'inc2734_wp_basis_posts_pagination_args',
  function( $args ) {
    return $args;
  }
);

inc2734_wp_basis_comments_pagination_args

/**
 * @see https://developer.wordpress.org/reference/functions/get_the_comments_pagination/
 * @param array $args
 * @return array
 */
add_filter(
  'inc2734_wp_basis_comments_pagination_args',
  function( $args ) {
    return $args;
  }
);

The Versions

27/07 2018

2.0.0

2.0.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

26/06 2018

1.0.1

1.0.1.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

14/06 2018

1.0.0

1.0.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

04/03 2018

0.7.7

0.7.7.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

04/03 2018

0.7.6

0.7.6.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

21/02 2018

0.7.5

0.7.5.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

06/02 2018

0.7.4

0.7.4.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

01/02 2018

0.7.3

0.7.3.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0-or-later

The Requires

  • php >=5.6

 

The Development Requires

28/12 2017

0.7.2

0.7.2.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

27/12 2017

0.7.1

0.7.1.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

11/12 2017

0.7.0

0.7.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

11/12 2017

0.6.0

0.6.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

05/12 2017

0.5.4

0.5.4.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

28/11 2017

0.5.3

0.5.3.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

24/11 2017

0.5.2

0.5.2.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

14/11 2017

0.5.1

0.5.1.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

24/10 2017

0.5.0

0.5.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

07/10 2017

0.4.4

0.4.4.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

06/10 2017

0.4.3

0.4.3.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

30/09 2017

0.4.2

0.4.2.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

11/08 2017

0.4.1

0.4.1.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

09/08 2017

0.4.0

0.4.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

21/07 2017

0.3.0

0.3.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

30/06 2017

0.2.3

0.2.3.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

29/06 2017

0.2.2

0.2.2.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.6

 

The Development Requires

16/06 2017

0.2.1

0.2.1.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.3

 

The Development Requires

16/06 2017

0.2.0

0.2.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.3

 

The Development Requires

16/06 2017

0.1.0

0.1.0.0

This library customizes HTML to use sass-basis in WordPress.

  Sources   Download

GPL-2.0+

The Requires

  • php >=5.3

 

The Development Requires