2017 © Pedro Peláez
 

library pdepend

Official version of pdepend to be handled with Composer

image

pdepend/pdepend

Official version of pdepend to be handled with Composer

  • Wednesday, December 13, 2017
  • by mapi
  • Repository
  • 25 Watchers
  • 405 Stars
  • 15,048,522 Installations
  • PHP
  • 823 Dependents
  • 5 Suggesters
  • 114 Forks
  • 81 Open issues
  • 49 Versions
  • 7 % Grown

The README.md

PHP Depend

Build Status Packagist codecov.io Scrutinizer Code Quality Chat to us on Gitter, (*1)

Documentation

PHP Depend for enterprise

Available as part of the Tidelift Subscription., (*2)

The maintainers of PHP Depend and thousands of other packages are working with Tidelift to deliver commercial support and maintenance for the open source dependencies you use to build your applications. Save time, reduce risk, and improve code health, while paying the maintainers of the exact dependencies you use. Learn more., (*3)

The Versions

13/12 2017

dev-master

9999999-dev

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

13/12 2017

2.5.2

2.5.2.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

06/12 2017

2.5.1

2.5.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

28/11 2017

dev-phpunit-6

dev-phpunit-6

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

19/01 2017

2.5.0

2.5.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

19/01 2017

dev-GH88-fully-qualified-classname-in-summary-report

dev-GH88-fully-qualified-classname-in-summary-report

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

11/01 2017

dev-GH282-php-7-group-use-declarations

dev-GH282-php-7-group-use-declarations

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

11/01 2017

2.4.1

2.4.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

10/01 2017

2.4.0

2.4.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

08/01 2017

dev-GH210-duplicate-dependency-references

dev-GH210-duplicate-dependency-references

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

08/01 2017

dev-GH290-unexpected-token-array

dev-GH290-unexpected-token-array

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

06/01 2017

dev-GH204-support-ellipsis-operator-in-function-call

dev-GH204-support-ellipsis-operator-in-function-call

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

06/01 2017

dev-GH285-unexpected-token-t_trait_c

dev-GH285-unexpected-token-t_trait_c

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

06/01 2017

dev-GH281-anonymous-class-parse-error

dev-GH281-anonymous-class-parse-error

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

06/01 2017

dev-GH269-unexpected-token-t_double_colon

dev-GH269-unexpected-token-t_double_colon

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

23/11 2016

2.3.2

2.3.2.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

23/11 2016

2.3.1

2.3.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

23/11 2016

dev-jimdelois-bugfix-anonymous-classes

dev-jimdelois-bugfix-anonymous-classes

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

22/11 2016

2.3.0

2.3.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

21/11 2016

2.2.6

2.2.6.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

21/11 2016

dev-nikic-php-parser

dev-nikic-php-parser

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

21/11 2016

2.2.5

2.2.5.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

18/09 2016

dev-php-parser-versions

dev-php-parser-versions

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

16/09 2016

dev-php7-anonymouse-class-declaration

dev-php7-anonymouse-class-declaration

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

10/03 2016

2.2.4

2.2.4.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

23/02 2016

2.2.3

2.2.3.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

19/02 2016

dev-GH238_php56_constant_expression_initializer

dev-GH238_php56_constant_expression_initializer

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

25/01 2016

dev-marco-jantke-symfony3-compat

dev-marco-jantke-symfony3-compat

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

16/10 2015

2.2.2

2.2.2.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

24/09 2015

2.2.1

2.2.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

20/09 2015

2.2.0

2.2.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

21/05 2015

2.1.0

2.1.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

02/03 2015

2.0.6

2.0.6.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

27/02 2015

2.0.5

2.0.5.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

04/12 2014

2.0.4

2.0.4.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

08/10 2014

2.0.3

2.0.3.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

08/10 2014

2.0.2

2.0.2.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

09/09 2014

2.0.1

2.0.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

21/05 2014

2.0.0

2.0.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

23/04 2014

2.0.0-beta.4

2.0.0.0-beta4

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

19/03 2014

2.0.0-beta.3

2.0.0.0-beta3

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

19/03 2014

2.0.0-beta.2

2.0.0.0-beta2

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

17/03 2014

2.0.0-beta.1

2.0.0.0-beta1

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

 

The Development Requires

04/12 2013

dev-release-1.1.x

dev-release-1.1.x

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

  • php >=5.2.3

 

04/12 2013

1.1.3

1.1.3.0

Official version of pdepend to be handled with Composer

  Sources   Download

BSD-3-Clause

The Requires

  • php >=5.2.3

 

25/07 2013

1.1.1

1.1.1.0

Official version of pdepend to be handled with Composer

  Sources   Download

The Requires

  • php >=5.2.3

 

12/09 2012

1.1.0

1.1.0.0

Official version of pdepend to be handled with Composer

  Sources   Download

The Requires

  • php >=5.2.3

 

29/04 2012

1.0.7

1.0.7.0

Official version of pdepend to be handled with Composer

  Sources   Download

The Requires

  • php >=5.2.3

 

29/04 2012

1.0.6

1.0.6.0

Official version of pdepend to be handled with Composer

  Sources   Download

The Requires

  • php >=5.2.3