2017 © Pedro Peláez
 

composer-installer module-installer

Custom installer for Nette modules

image

flame/module-installer

Custom installer for Nette modules

  • PHP
  • 4 Dependents
  • 0 Suggesters
  • 2 Forks
  • 0 Open issues
  • 4 Versions
  • 6 % Grown

The README.md

Nette Module Installer

This is a custom installer for Composer packaging system which helps installing Nette Modules., (*1)

Creating an Module

To create a new Nette Module, simply create it as a Composer package. There are only a few differences from normal Composer packages:, (*2)

  1. Set type to nette-module
  2. Add this installer as a requirement: flame/module-installer: @dev
  3. Set extra section of composer.json

Here is an example:, (*3)

{
    "extra": {
        "module": {
            "class": "Flame\\CMS\\ErrorModule\\DI\\ErrorExtension",
            "name": "Error"
        }
    }
}

Name is optional, (*4)

Look at this composer.json for full example., (*5)

Your extension will be added into app/config/extensions.(php|neon) file, (*6)

Please create first the file with php or neon extension, (*7)

The Versions

22/08 2013

dev-master

9999999-dev https://github.com/flame-org/Nette-Module-Installer

Custom installer for Nette modules

  Sources   Download

GPLv2 GPLv3 BSD-3

The Requires

  • php >= 5.3.0

 

The Development Requires

installer modules nette

22/08 2013

v0.1.2

0.1.2.0 https://github.com/flame-org/Nette-Module-Installer

Custom installer for Nette modules

  Sources   Download

GPLv2 GPLv3 BSD-3

The Requires

  • php >= 5.3.0

 

The Development Requires

installer modules nette

20/08 2013

v0.1.1

0.1.1.0 https://github.com/flame-org/Nette-Module-Installer

Custom installer for Nette modules

  Sources   Download

GPLv2 GPLv3 BSD-3

The Requires

  • php >= 5.3.0

 

The Development Requires

installer modules nette

28/07 2013

v0.1.0

0.1.0.0 https://github.com/flame-org/Nette-Module-Installer

Custom installer for Nette modules

  Sources   Download

GPLv2 GPLv3 BSD-3

The Requires

  • php >= 5.3.0

 

The Development Requires

installer modules nette