2017 © Pedro Peláez
 

composer-plugin composer-versions-check

Checks if packages are up to date to last major versions after update

image

sllh/composer-versions-check

Checks if packages are up to date to last major versions after update

  • Thursday, January 11, 2018
  • by Soullivaneuh
  • Repository
  • 7 Watchers
  • 163 Stars
  • 157,826 Installations
  • PHP
  • 11 Dependents
  • 0 Suggesters
  • 4 Forks
  • 12 Open issues
  • 12 Versions
  • 23 % Grown

The README.md

composer-versions-check

composer-versions-check is a plugin for Composer., (*1)

It warns user for outdated packages from last major versions after update command., (*2)

Latest Stable Version Latest Unstable Version License Dependency Status Reference Status, (*3)

Total Downloads Monthly Downloads Daily Downloads, (*4)

Build Status Scrutinizer Code Quality Code Climate Coverage Status SensioLabsInsight, (*5)

composer-versions-check_demo, (*6)

Screencast provided by Silentcast., (*7)

Installation

You can install it either globally (recommended):, (*8)

composer global require sllh/composer-versions-check

or locally:, (*9)

composer require sllh/composer-versions-check

Usage

That's it! Composer will enable automatically the plugin as soon it's installed., (*10)

Just run composer update command to see the plugin working., (*11)

Configuration

You can configure the plugin via the COMPOSER_HOME/config.json file. Here is the default one:, (*12)

{
    "config": {
        "sllh-composer-versions-check": {
            "show-links": false
        }
    }
}
  • show-links: Shows outdated package links. Set to true to get a larger output, like the demo.

The Versions

11/01 2018

dev-master

9999999-dev

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • composer-plugin-api ^1.0
  • php ^5.3 || ^7.0

 

The Development Requires

plugin composer update versions

11/01 2018

dev-flintci

dev-flintci

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

11/01 2018

dev-flintci-778

dev-flintci-778

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

16/06 2017

v2.0.3

2.0.3.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

29/04 2016

v2.0.2

2.0.2.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

26/04 2016

v2.0.1

2.0.1.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

19/04 2016

v2.0.0

2.0.0.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

19/04 2016

1.x-dev

1.9999999.9999999.9999999-dev

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

19/04 2016

v1.1.0

1.1.0.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • php ^5.3 || ^7.0
  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

12/10 2015

v1.0.2

1.0.2.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

06/10 2015

v1.0.1

1.0.1.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions

04/10 2015

v1.0.0

1.0.0.0

Checks if packages are up to date to last major versions after update

  Sources   Download

MIT

The Requires

  • composer-plugin-api ^1.0

 

The Development Requires

plugin composer update versions