2017 © Pedro Peláez
 

library phalex

Library build on top PhalconPHP Framework

image

tmquang6805/phalex

Library build on top PhalconPHP Framework

  • Tuesday, March 17, 2015
  • by tmquang6805
  • Repository
  • 1 Watchers
  • 4 Stars
  • 49 Installations
  • PHP
  • 1 Dependents
  • 0 Suggesters
  • 1 Forks
  • 0 Open issues
  • 5 Versions
  • 0 % Grown

The README.md

Welcome To Phalex

Build Status Scrutinizer Code Quality Build Status Code Coverage Latest Stable Version Total Downloads License, (*1)

Introduction

The name Phalex is a contraction of the words [Phal]con [Ex]tension.
Phalcon is good, which is the fastest one PHP framework. However, when I develop web applications based on the Phalcon native, I realized most is the lambda functions. This is not bad, fast development, but in my opinion, it is somewhat difficult to maintain and manage code. So, I built this project aims to pack a few things, such as the application configurations, routing ..., (*2)

Phalex bases on Plug & Play Multi Modules mechanism, so you can easy to develop multiple modules for your application. Something good in Phalex, (*3)

  • Configuration in Phalex application will be separated in each module. When runtime, Phalex auto merges all configurations into one, and you can easy to cache them.
  • You must not set view service for each module, Phalex bases on DRY concept, so you just config views_dir for module, when runtime, Phalex auto set view service for yours.
  • Router handler via configuration.
  • Auto load for each module via configuration and you can call class cross modules.
  • Default Error Handler, and you easy to extend or replace Phalex Error Handler
  • Highly Unit test with PHPUnit
  • And more ...

System Requirements

  • Require PHP 5.5 or later. (We recommend using latest PHP version whenever possible)
  • Phalcon Framework 1.3 or later (I don't test with Phalcon Framework 2.0, so I don't recommend use version 2.0 with Phalex)

The Versions

17/03 2015

dev-master

9999999-dev

Library build on top PhalconPHP Framework

  Sources   Download

MIT

The Requires

 

The Development Requires

extension library phalcon

17/03 2015

v1.1-rc1

1.1.0.0-RC1

Library build on top PhalconPHP Framework

  Sources   Download

MIT

The Requires

 

The Development Requires

extension library phalcon

15/02 2015

dev-develop

dev-develop

Library build on top PhalconPHP Framework

  Sources   Download

MIT

The Requires

 

The Development Requires

extension library phalcon

29/12 2014

v1.0.1

1.0.1.0

Library build on top PhalconPHP Framework

  Sources   Download

MIT

The Requires

 

The Development Requires

extension library phalcon

28/12 2014

v1.0.0

1.0.0.0

Library build on top PhalconPHP Framework

  Sources   Download

MIT

The Requires

 

The Development Requires

extension library phalcon