2017 © Pedro Peláez
 

library aliyun-openapi-php-sdk

aliyun-openapi-php-sdk

image

skywit/aliyun-openapi-php-sdk

aliyun-openapi-php-sdk

  • Tuesday, March 21, 2017
  • by skywit
  • Repository
  • 2 Watchers
  • 1 Stars
  • 752 Installations
  • PHP
  • 0 Dependents
  • 0 Suggesters
  • 312 Forks
  • 0 Open issues
  • 2 Versions
  • 3 % Grown

The README.md

Open API SDK for php developers

Requirements

  • PHP 5.3+

Build

  • to run unit tests, you will have to configure aliyun-sdk.properties files in your user directory, and make sure your project has corresponding service enabled, eg. openmr.

Example

include_once '../aliyun-php-sdk-core/Config.php';
use Ecs\Request\V20140526 as Ecs;

$iClientProfile = DefaultProfile::getProfile("cn-hangzhou", "<your accessKey>", "<your accessSecret>");
$client = new DefaultAcsClient($iClientProfile);

$request = new Ecs\DescribeRegionsRequest();
$request->setMethod("GET");
$response = $client->getAcsResponse($request);
print_r($response);

Authors && Contributors

License

licensed under the Apache License 2.0, (*1)

The Versions

21/03 2017

dev-master

9999999-dev

aliyun-openapi-php-sdk

  Sources   Download

MIT

The Requires

  • php >5.3

 

by Avatar skywit

aliyun-openapi-php-sdk

21/03 2017

v1.0.0

1.0.0.0

aliyun-openapi-php-sdk

  Sources   Download

MIT

The Requires

  • php >5.3

 

by Avatar skywit

aliyun-openapi-php-sdk