2017 © Pedro Peláez
 

drupal-drush drupal-code-builder-drush

Provides Drush commands for generating Drupal code using Drupal Code Builder.

image

drupal-code-builder/drupal-code-builder-drush

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  • Monday, July 16, 2018
  • by joachim-n
  • Repository
  • 1 Watchers
  • 8 Stars
  • 611 Installations
  • PHP
  • 1 Dependents
  • 0 Suggesters
  • 1 Forks
  • 2 Open issues
  • 10 Versions
  • 66 % Grown

The README.md

This is a set of Drush commands for generating code with the Drupal Code Builder library (https://github.com/drupal-code-builder/drupal-code-builder)., (*1)

The 9.x branch works with Drush 9. For Drush 8, use the 8.x branch., (*2)

Installation

There are two ways to install this command:, (*3)

  • Composer installation as a Drush extension
    1. Do composer require drupal-code-builder/drupal-code-builder-drush to install this package and its dependencies. You will need your project to use drupal-composer/drupal-project, or have your composer.josn configured to place Drush extensions into drush/contrib.
  • Manual installation as Drush extension
    1. Place this somewhere Drush will locate it as a command, such as drush/contrib.
    2. Do composer require drupal-code-builder/drupal-code-builder to install the Drupal Coder Builder library.

Once this is installed, do drush cbu. This detects hooks, services, and plugin types in your Drupal site's codebase and analyses them for use with Drupal Code Builder., (*4)

Usage

The following commands are available:, (*5)

  • drush cb:list: Lists all the hooks, services, and plugins that Drupal Code Builder has detected in your Drupal site's codebase.
  • drush cb:update: Updates the stored definitions of Drupal hooks, services and plugin types.
  • drush cb:module: Creates a module, or adds components to one.

A note on history

Commits in this repository older than 2017-08-22 are extracted from other repositories that originally were the home of this command file: the drupal.org module_builder project, and a drush fork. They were extracted using git filter-branch, and reconstituted into a single history with git graft and git filter-branch., (*6)

The Versions

16/07 2018

9.x-dev

9.9999999.9999999.9999999-dev

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

16/07 2018

9.0.1

9.0.1.0

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

16/11 2017

9.0.0

9.0.0.0

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

09/11 2017

8.x-dev

8.9999999.9999999.9999999-dev

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

09/11 2017

8.2.1

8.2.1.0

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

05/11 2017

8.2.0

8.2.0.0

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

01/11 2017

9.0.0-alpha3

9.0.0.0-alpha3

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

01/11 2017

8.1.0

8.1.0.0

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

06/10 2017

dev-9.x-clean

dev-9.x-clean

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires

13/09 2017

dev-sandbox-fake-module

dev-sandbox-fake-module

Provides Drush commands for generating Drupal code using Drupal Code Builder.

  Sources   Download

GPL-2.0+

The Requires

 

The Development Requires